Справочные материалы по 1С

Работа с HTML-документами в 1С 8.x

Заполнение HTML-анкет (пример формы)
Фамилия
Имя
Отчество

Процедура URLПриИзменении(Элемент) 
	ЭлементыФормы.ПолеHTML.Перейти(URL); 
КонецПроцедуры 

Процедура ПолеHTMLДокументСформирован(Элемент) 
	// Событие возникает и при открытии формы, когда в реквизите 
	// URL содержится пустая строка. 
	Если URL <> "" Тогда 
		Док = ЭлементыФормы.ПолеHTML.Документ; 
		// При попытке обратиться к несуществующему свойству 
		// произойдет ошибка 
		Док.forms["frm"].fam.Value = "Иванов"; 
		Док.forms["frm"].nam.Value = "Иван"; 
		Док.forms["frm"].otch.Value = "Иванович"; 
	КонецЕсли; 
КонецПроцедуры           



Задайте вопрос программисту 1С

+7 901 312 83 57